nixos-config/profiles/security/password-store.nix
2024-06-19 15:49:07 +03:00

13 lines
382 B
Nix

{ config, inputs, ... }: {
sops.secrets.git-ssh-key = {
owner = config.mainuser;
sopsFile = inputs.self.secretsDir + /misc.yaml;
};
services.password-store = {
enable = true;
repo = "gitea@code.ataraxiadev.com:AtaraxiaDev/pass.git";
sshKey = config.sops.secrets.git-ssh-key.path;
};
persist.state.homeDirectories = [ ".local/share/password-store" ];
}