25 lines
564 B
Nix
25 lines
564 B
Nix
{ config, lib, ... }:
|
|
with config.deviceSpecific;
|
|
{
|
|
options = with lib;
|
|
with types; {
|
|
defaultApplications = mkOption {
|
|
type = attrsOf (submodule ({ ... }: {
|
|
options = {
|
|
cmd = mkOption { type = path; };
|
|
desktop = mkOption { type = str; };
|
|
};
|
|
}));
|
|
description = "Preferred applications";
|
|
};
|
|
|
|
startupApplications = mkOption {
|
|
type = listOf str;
|
|
description = "Applications to run on startup";
|
|
};
|
|
};
|
|
config = {
|
|
defaultApplications = {};
|
|
};
|
|
}
|