100 lines
3.0 KiB
Nix
100 lines
3.0 KiB
Nix
{
|
|
nixConfig = {
|
|
extra-substituters = "https://nix-community.cachix.org";
|
|
extra-trusted-public-keys = "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs=";
|
|
};
|
|
|
|
inputs = {
|
|
nixpkgs.url = "nixpkgs/nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
crane = {
|
|
url = "github:ipetkov/crane";
|
|
inputs = {
|
|
flake-utils.follows = "flake-utils";
|
|
nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
fenix = {
|
|
url = "github:nix-community/fenix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
advisory-db = {
|
|
url = "github:rustsec/advisory-db";
|
|
flake = false;
|
|
};
|
|
};
|
|
|
|
outputs = { self, crane, fenix, flake-utils, nixpkgs, advisory-db }@inputs:
|
|
flake-utils.lib.eachDefaultSystem (system:
|
|
let
|
|
pkgs = import nixpkgs {
|
|
inherit system;
|
|
};
|
|
inherit (pkgs) lib;
|
|
fenix-pkgs = fenix.packages.${system};
|
|
rust-toolchain = fenix-pkgs.default.toolchain;
|
|
craneLib = crane.lib.${system}.overrideToolchain rust-toolchain;
|
|
src = craneLib.cleanCargoSource ./.;
|
|
buildInputs = [
|
|
|
|
] ++ lib.optionals pkgs.stdenv.isDarwin [
|
|
pkgs.libiconv
|
|
];
|
|
|
|
cargoArtifacts = craneLib.buildDepsOnly {
|
|
inherit src buildInputs;
|
|
};
|
|
|
|
my-crate = craneLib.buildPackage {
|
|
inherit cargoArtifacts src buildInputs;
|
|
doCheck = false;
|
|
};
|
|
in
|
|
{
|
|
checks = {
|
|
# Build the crate as part of `nix flake check` for convenience
|
|
inherit my-crate;
|
|
# Run clippy (and deny all warnings) on the crate source.
|
|
my-crate-clippy = craneLib.cargoClippy {
|
|
inherit cargoArtifacts src buildInputs;
|
|
cargoClippyExtraArgs = "--all-targets -- --deny warnings";
|
|
};
|
|
my-crate-doc = craneLib.cargoDoc {
|
|
inherit cargoArtifacts src buildInputs;
|
|
};
|
|
# Check formatting
|
|
my-crate-fmt = craneLib.cargoFmt {
|
|
inherit src;
|
|
};
|
|
# Audit dependencies
|
|
my-crate-audit = craneLib.cargoAudit {
|
|
inherit src advisory-db;
|
|
};
|
|
# Run tests with cargo-nextest
|
|
# Consider setting `doCheck = false` on `my-crate` if you do not want
|
|
# the tests to run twice
|
|
my-crate-nextest = craneLib.cargoNextest {
|
|
inherit cargoArtifacts src buildInputs;
|
|
partitions = 1;
|
|
partitionType = "count";
|
|
};
|
|
} // lib.optionalAttrs (system == "x86_64-linux") {
|
|
# Check code coverage (note: this will not upload coverage anywhere)
|
|
my-crate-coverage = craneLib.cargoTarpaulin {
|
|
inherit cargoArtifacts src;
|
|
};
|
|
};
|
|
|
|
packages.default = my-crate;
|
|
|
|
apps.default = flake-utils.lib.mkApp {
|
|
drv = my-crate;
|
|
};
|
|
|
|
devShells.default = pkgs.mkShell {
|
|
inputsFrom = builtins.attrValues self.checks;
|
|
nativeBuildInputs = [ rust-toolchain fenix-pkgs.rust-analyzer ];
|
|
};
|
|
});
|
|
}
|